Start a conversation

Changing Minecraft Versions

Changing your Minecraft version can let you choose which version to join the Hypixel server with! You can change your Minecraft version to any of our supported versions and you will be able to play on the Hypixel server.

Hypixel currently supports the following versions:

  • 1.8
  • 1.11
  • 1.12
  • 1.13
  • 1.14
  • 1.15
  • 1.16


Best version for Hypixel is 1.8.9
Minecraft version 1.8.9 is the most optimized client for our network and for the best player experience we recommend you use 1.8.9. Other versions of Minecraft, such as 1.11 and higher, will work on the Hypixel server but due to system changes it impacts our servers differently.

⚠️
 We are considering dropping support for 1.11 to 1.15 at a later date to make sure we offer the best possible experience for 1.8, 1.16 and future versions of Minecraft.

 How to change your Minecraft Version
To change your Minecraft version, head back to your launcher. You can click the up arrow next to the green Play button to bring it back to the latest released version of Minecraft.


You can also change your version to an older one by going to Launcher Options. Clicking "Add New" will bring up a new configuration which lets you use a different version of Minecraft.


You can name it and change the version in this menu. If it says "release", then it is an official version of Minecraft. If it says "snapshot", then it is a testing version of Minecraft. Snapshots may not be able to connect to the Hypixel Server, we advise you use official releases only.


Hit save and go back to the News tab. You now have a new version of Minecraft that you can play on!


Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Hypixel Support

  2. Posted
  3. Updated

Comments